Hello There, Guest! Register

Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Installation problem
06-18-2012, 10:36 AM (This post was last modified: 06-18-2012 11:28 AM by koldKat.)
Post: #1
Installation problem
When attempting to install (very first step), I get this error:

Code:
extension_dir does not exist: /usr/lib/php/modules/

But it does exist:

Code:
[root@localhost modules]# pwd
/usr/lib/php/modules

And I do have SourceGuardian, which is also correct in the global php.ini file:

Code:
[root@localhost modules]# ls
bcmath.so  calendar.so  dba.so   ftp.so  gettext.so  iconv.so  ixed.5.2.lin    mysqli.so  openssl.so    phar.so   shmop.so  sockets.so  sysvsem.so  xmlrpc.so
bz2.so     curl.so      exif.so  gd.so   gmp.so      imap.so   ixed.5.2ts.lin  mysql.so   pdo_mysql.so  posix.so  soap.so   sysvmsg.so  sysvshm.so  zip.so

Any help on the issue, please?
I've made progress, however I come up with this now:

Code:
PHP script /srv/http/install/index.php is protected by SourceGuardian and requires the SourceGuardian loader ixed.5.4.lin. The SourceGuardian loader has not been installed, or is not installed correctly. Please find the required loader within SourceGuardian installation directory or visit the SourceGuardian php encoder site to download it.

The latest loader is 5.3. Where am I supposed to get the 5.4 it's asking for?
This is what I get now:

Code:
Mon Jun 18 11:25:28 2012] [error] [client 94.26.5.143] PHP Fatal error:  Call to undefined function dl() in /srv/http/install/index.php on line 2

Please help.
Find all posts by this user
Quote this message in a reply
06-18-2012, 12:08 PM
Post: #2
RE: Installation problem
I recommend upgrading to php 5.3 and using the ixed 5.3 loader. If you read the FAQ you will see there is an alternative way to get sourceguardian to work.

The issue you are facing here seems to be your server, there are others who have reported similar problems:
http://www.byte.nl/blog/2011/01/17/php-u...undefined/
http://no.php.net/dl
Find all posts by this user
Quote this message in a reply
06-18-2012, 12:12 PM
Post: #3
RE: Installation problem
I realized SourceGuard doesn't support PHP 5.4 (yet), hence there is no ixed.5.4. In other words, I have to downgrade to PHP 5.3, rather than upgrade Sad
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)