Hello There, Guest! Register

Thread Closed 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Errors - Read this before asking!
11-05-2012, 12:42 PM (This post was last modified: 02-25-2013 12:45 PM by admin.)
Post: #1
Errors - Read this before asking!
Quote:Warning: move_uploaded_file(/home/username/public_html/plugins/clix_forum/avatars/tmp/127e.png) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/username/ClixScript_PHP_DOCS/classes/class.upload.php on line 136
This is currently rated as top 1 clixscript error, the cause of this issue is simply laziness. Because, it says, in the readme.txt file, that you need to chmod a certain number of folders, if you skip that, you will get this error.

But don't worry, its a 30 second fix, just go ahead and chmod the folder 777 (or in some cases 755).

In this example above you would need to chmod /avatars/tmp/ and /avatars/ to 777 for it to work.

Quote:Ads won't reset!!
This "bug" has been pestering our community since the dawn of time, but it's not really a bug at all. If you have trouble with ads not reseting you have trouble with cron job not running. (but ad resetting is happening inside the cron job, and other tasks it does might not be as obvious). See next question about "cron job" not working on how to solve the issue. If you really don't give a damn, we have open sourced the code and you can do whatever you want with it, so reset ads using this code if you want: link

Quote:Cron job won't run?
1. Make sure they are setup like shown here.
2. Make sure the hash matches the one specified in your admin area
3. Make sure that your domain doesn't redirect from say www. to without www. if you are using www. in url of the cron job. Basically, the cron job must not redirect!
4. Does your host have trouble running the cron command perhaps? Ask your host for help if none of the above works, they should be able to solve your issues. (some hosts doesn't allow "lynx > /dev/null-dump" command, which means you'll have to use another one). You may try to use the command:
wget "url"
replace url with your url... Some servers that didn't work with lynx worked with wget.
5. Is your server too weak? Make sure you host with somebody that allows running big cron jobs.

Quote:Referral clicks won't credit, graph in account balance doesn't update?
If you have set minimum referral clicks per day (under membership settings in admin) user must click x number of ads to earn from referrals, if he does not the graphs won't update and neither will he get credited anything. It could also be cause of the hourly cron job not running.

Quote:Critical DB Error!
Date: [21-10-2012 18:41:29]
MySQL Error: [Table 'some_table' doesn't exist]

If you get this message, or anything like it (replace some_table with another table name) you most likely did not run upgrade.php when doing an upgrade. So do that and your db should be up to date. If not, feel free to create a ticket.

Quote:PHP Fatal error: Call to undefined function dl()
You need to downgrade (or maybe upgrade) to version 5.3 of PHP. If that doesn't solve it, you must make sure sourceguardian is installed correctly, ask your host for that,

Quote:Postback doesn't work?
1. Make sure you have entered postback url over at the affiliate network.
2. If you are using version 2.53 or less then please make sure you are not using the variable "id", instead use variable such as "cid".

Quote:When upgrading I'm getting "Critical error, invalid version" ?
You have entered invalid database name (or maybe username). Correct it and try again, it will then work.

Quote:How does the template system work, how do I edit template?
Read template.txt which is included with the script.

Quote:PHP script /home/user/ClixScript_PHP_DOCS/classes/class.vars.php is protected by SourceGuardian and requires the SourceGuardian loader ixed.5.2.lin. The SourceGuardian loader has not been installed, or is not installed correctly. Please find the required loader within SourceGuardian installation directory or visit the SourceGuardian php encoder site to download it.
This error means that you do not have SourceGuardian installed. There are two ways to solve this.

- Ask host: Contact your host and ask them to install SourceGuardian (recommend)

- Do it yourself (won't work on all servers):
1. Create a file "php.ini" inside your public_html directory

2. Create a folder "extensions" in your public_html directory

3. Go to: http://www.sourceguardian.com/ixeds/ and download the correct extensions (how do you know? You must find out which OS your server is running, you can find this out by looking in your cPanel or asking your host. E.g if you are running linux 32-bit, download that zip. After download, extract "ixed.5.2.lin" and upload it into your "extensions" directory.

4. Finally edit your php.ini file (the one you placed in public_html) and enter the following line:


Replace "username" with your username... or replace the path if it's not correct.

5. If you are going to install the script please make a copy of that php.ini file and place it in public_html/install.

6. That's all!

Quote:PC Point Plugin is getting this error "Cannot modify header". Whats wrong?
Nothing is wrong, it's working, but PC Point Plugin does not have an admin panel, what you need to do is go to membership settings, there you will find the PC Point paramters to adjust.

Quote:Fatal error: Cannot redeclare hex2bin() in /home/incentiv/public_html/demo/ClixScript_PHP_DOCS/classes/class.bux.php on line 314
Congratulations for being on an up-to date server, hex2bin is caused by the newest version php 5.4 and can easily be solved by downloading and re-uploading classes/class.bux.php !
Find all posts by this user
Thread Closed 

Forum Jump:

User(s) browsing this thread: 1 Guest(s)